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Chapter 1

Installation

System requirements

WinNonlin Professional

The following system configuration is needed for WinNonlin® Professional.

Note: Installation on Windows NT or Windows 2000 requires administrator rights.

Table 1-1. System requirements for WinNonlin Professional

Item Minimum Recommended
System software Windows 98, 2000, XP or NT with 

service pack 3 or later, 
or Citrix MetaFrame XP

Windows 2000

Browser (to view 
online help)

Microsoft Internet Explorer 5.0 or 
higher

Processor Pentium 133 MHz Pentium 350 MHz or faster
RAM 32 MB 64 MB

Hard disk space: 
system drivea

a. Hard drive on which the operating system is loaded, typically the C drive. 

70 MB

Hard disk space: 
installation driveb

b. Hard drive onto which WinNonlin will be installed.

60 MB

Graphics SVGA
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WinNonlin Enterprise with PKS

WinNonlin Enterprise can serve as a client interface for the Pharsight Knowl-
edgebase Server™ (PKS). This functionality requires a faster processor and 
more memory than are needed to run WinNonlin without PKS. 

The following system configuration is recommended to use WinNonlin Enter-
prise with PKS.

Installing WinNonlin
WinNonlin installation requires read/write access to: 1. the Windows system 
directory; 2. the installation directory, and 3. the directory in which WinNon-
lin stores common files (C:\PROGRAM FILES\COMMON FILES\PHARSIGHT). 
The files in items 1 and 3 above are used internally by the application.

Note: Installation instructions for the Pharsight Knowledgebase Server appear sepa-
rately, in the PKS System Administrator’s Guide.

Table 1-2. System requirements for WinNonlin Enterprise with PKS

Item Minimum Recommended
System software Windows 98, 2000, XP or NT with 

service pack 3 or later, 
or Citrix MetaFrame XP

Windows 2000

Browser (to view 
online help)

Microsoft Internet Explorer 5.0 or 
higher

Internet Explorer 6.0 or higher

Processor Pentium III 500MHz Pentium III 700MHz
RAM 128 MB 192 MB

Hard disk space: 
system drivea

a. Hard drive on which the operating system is loaded, typically the C drive. 

70 MB

Hard disk space: 
installation driveb

b. Hard drive onto which WinNonlin will be installed.

60 MB

Graphics SVGA
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Pharsight common files

Installing WinNonlin on a machine that has WinNonMix® or Trial Simulator 
installed may update some common files, shared between products. The other 
Pharsight products will continue to operate correctly. 

Temporary files directory

It is possible to specify the location to which WinNonlin will store temporary 
files. This is done by setting the TMP and TEMP environment variables in the 
Windows operating system. The WinNonlin user must have read/write access 
to the temporary file location(s). Changing this setting requires administrative 
rights on the machine.

To set the temporary files directory on Windows 98:

1. In the Windows Start menu, choose Run...

2. Run the System Configuration Editor as follows:

a. Type sysedit in the Open field.
b. Click OK. 

3. Add the temporary directory definition to the file AUTOEXEC.BAT. For exam-
ple, to set the temporary directory to C:\TEMP:
a. In the autoexec.bat window, enter the text: 

SET TMP=C:\TEMP

SET TEMP=C:\TEMP

b. Save the file and exit the System Configuration Editor, by choosing 
File>Save, then File>Exit in the menus.
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To set the temporary files directory on Windows NT or Windows 2000:

1. In the Windows Start menu, choose Settings>Control Panel.

2. Open the System control panel, Advanced tab. 

3. Click on the Environment Variables button to open the following dialog.

4. Use the upper Edit button to set the variables TMP and TEMP in the User 
Variables list box. Set both to point to the desired temporary files directory. 
Make sure that the directory path exists on the machine. 

Note: This action changes the temporary files directory for all applications on the 
system.

Updating WinNonlin

If a prior version of WinNonlin has been installed on the machine, the instal-
lation wizard will identify and uninstall it. If WinNonlin 3.1 or earlier exists 
on the machine, it may be necessary to manually uninstall it.
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The installation procedure

To install WinNonlin:

1. Close all Windows applications.

2. If an anti-virus program is running on the machine, turn it off before installing 
WinNonlin. Anti-virus programs can severely degrade installation perfor-
mance. If the WinNonlin CD must be checked for viruses, run the virus scan-
ning software on the CD (being sure to scan all compressed files) before 
installing the application.

3. Insert the WinNonlin CD into the machine’s CD-ROM drive. 

4. If the Installation Wizard does not start automatically:
a. From the Windows Start menu select Run. 
b. In the Run dialog box, type d:\setup, where d is the letter assigned to 

the CD-ROM drive, and click OK.

5. The software will scan the machine for a previous installation of WinNonlin. 
If one is located, step through the un-installation process, and click the Finish 
button when it completes. Any previously-installed license will be saved to be 
applied to the new version. Re-launch the installer (step 4 above) to proceed. 

Note: It may be necessary to manually uninstall WinNonlin versions prior to 3.1.

6. The InstallShield Wizard for WinNonlin will appear.
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7. Click Next to proceed to the license agreement. 

8. Read the agreement. To accept its terms and proceed with the installation, 
select I accept the terms of the license agreement and click Next. Else, 
please contact Pharsight’s sales department at sales@pharsight.com. 

9. Both Complete and Custom installations will install the WinNonlin software, 
Pharsight Licensing Manager, and WinNonlin user documentation and exam-
ple files. The Custom install will indicate the disk space required: approxi-
mately 40 MB. 

mailto:sales@pharsight.com
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10. Click Next to proceed with the installation. Use the Change... button in this 
dialog to set the directory to contain the WinNonlin program files. 

11. Click Next.

12. Click Install to load the following content:

Table 1-3. WinNonlin installation content

Description Default location
WinNonlin software and 
online help

C:\Program Files\Pharsight\WinNonlin
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Note: Network Administrators and Information Technology personnel may contact 
Pharsight Customer Support (support@pharsight.com) for a complete list of 
files that are installed with WinNonlin 4.1, and their default locations. 

The InstallShield Wizard will reappear when the installation is complete. 

13. Click Finish to exit the wizard.

14. WinNonlin includes a 30-day license. Installation of an annual license is 
required for WinNonlin to continue running after the trial license expires: 
a. If a current license from a prior WinNonlin installation exists on the 

machine, no action is required. The Install Wizard will automatically load 
the previous license for use with the new version of WinNonlin. 

b. If the installation is new, or the prior license has expired, follow the 
instructions in Chapter 2 to install or update the product license.

Pharsight License Wizard C:\Program Files\Pharsight\WinNonlin
Example data files C:\Program Files\Pharsight\WinNonlin\Examples
User manuals C:\Program Files\Pharsight\WinNonlin\WNL4.1 User Docs

Table 1-3. WinNonlin installation content

Description Default location

mailto:support@pharsight.com
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CAUTION: The WinNonlin CD jewel case contains the product ID number and license 
key code. These numbers are required for installing a license, purchasing 
renewals or upgrades, and obtaining customer support. Store the CD and 
jewel case in a safe place.
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Chapter 2

Licensing

Installation and renewal of WinNonlin 
software licenses

The license key code and product tracking ID 
WinNonlin requires installation of a current annual license key code. There 
are two types of license key codes:

1. A node license key code activates the software on the machine on which it 
is installed. The license agreement restricts installation of the software 
and license to a single personal computer (PC) per node license.

2. A floating license key code enables multiple PC’s in a networked environ-
ment to run the product using a shared pool of software licenses. The 
number of simultaneous users is limited to the total number of licenses on 
the license server.

One license key code and one product tracking ID are included with each 
license or set of licenses purchased. For mail shipments, the key code and 
product tracking ID are located on the packing slip shipped with the software, 
and on the product’s CD jewel case. The packing slip indicates the type of 
license purchased. For electronic license renewals, the key code, product 
tracking ID and license type are sent by e-mail. 

Please include the product tracking ID in all correspondence with Pharsight 
Corporation about the product and its license, including license renewals, 
software updates and product upgrades.

Existing license key codes

The WinNonlin installation program will search for any previously-installed 
WinNonlin license key code. If a current key code is located, the installation 
will automatically set it up for use with the updated WinNonlin software.
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Installing a node license key code
WinNonlin must be installed before the license key code can be installed. See 
“Installing WinNonlin” on page 2. 

The same procedure is used to install a new license or renew an existing one. 

To install a node license:

1. From the Windows Start menu, select Programs>Pharsight>WinNonlin 
4.1>Pharsight License Wizard.

This opens the Pharsight Licensing Wizard.

2. Choose the Node License button. This opens the following dialog. Any previ-
ously-installed WinNonlin license key code will be detected and pre-filled in 
the License Key Code field.



Licensing
Installing a node license key code

13

2

3. Enter the Product Tracking ID, which was included with the WinNonlin ship-
ment or license renewal e-mail. 

Note: The product tracking ID will be needed for future correspondence with Phar-
sight regarding the software or license. To view it, re-open the Pharsight 
Licensing Wizard. Alternately, e-mail the license file, LSERVRC in the Win-
Nonlin installation directory, with the service request to support@phar-
sight.com for technical support or to sales@pharsight.com for license 
renewals or product upgrades.

4. Enter the user information (optional). This information will be saved in the 
license key file, LSERVRC, which you may use to provide Pharsight with con-
tact and license information for license renewals and customer support.

5. Enter the license key code. This number was included with your product ship-
ment or license renewal e-mail. 

6. Click the Install License Key button to save the information to the license 
key file and install the license.

7. Click Exit to close the Pharsight Licensing Wizard. It is now possible to run 
WinNonlin for the term of the license.

mailto:support@pharsight.com
mailto:support@pharsight.com
mailto:sales@pharsight.com
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Installing a floating license key code
The Pharsight Floating License Server software must be installed on the 
server machine before the floating license can be installed and activated on 
each client machine. 

Note: Contact Pharsight Customer Support for suggestions on automated deploy-
ment of network (floating) versions of Pharsight software.

To install the floating license server:

1. On the server machine, run the file: \PHARSIGHT FLOATING NETWORK 
LICENSE SERVER\SETUP.EXE from the WinNonlin CD. 

2. Follow the instructions in the installation wizard. 

Note: The License Server must be installed in the process space of the intended 
server machine; that is, it must be installed while operating on the server 
machine itself, and not via a mapped drive on a client machine.

To install a floating license:

1. Open the Windows Start menu on the network server and choose Pro-
grams>Pharsight>Pharsight Floating License Server>Pharsight License 
Wizard for Server. 

This opens the Pharsight License Wizard for Server dialog, shown below.



Licensing
Installing a floating license key code

15

2

2. Enter the Product Tracking ID, which was included with your WinNonlin 
shipment or license renewal e-mail. Refer to this number in all correspon-
dences with Pharsight about this product license. 

Note: To locate the Product Tracking number after installation, re-open the Phar-
sight Licensing Wizard; alternately, e-mail the license server file, LSERVRC in 
the WinNonlin installation directory, to license@pharsight.com.

3. Enter the contact information, if desired. This information will be saved in the 
license key file, which you may use to provide Pharsight with contact and 
license information for license renewals and customer support.

4. Enter the license key code, included with your product shipment or license 
renewal e-mail.

5. Click the Install License Key button to save the information to the license 
key file and install the license. Click OK in the confirmatory dialog.

6. Click the Exit button to close the wizard.

7. On each client machine, install WinNonlin following the instructions under 
“Installing WinNonlin” on page 2, then set up the licensing as follows.

mailto:license@pharsight.com
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8. From the client machine’s Windows Start menu, choose Program 
Files>Pharsight>WinNonlin>Pharsight License Wizard.

9. Click the Floating License button. The Wizard opens a new dialog requesting 
the name of the license server.

10. Enter the name of the network server on which the Pharsight Floating Net-
work License Server has been installed.

11. Click Enable client PC to use License Server.

12. A message appears confirming installation of the license code. Click OK.

13. Click Exit to exit the Licensing Wizard. Repeat steps 7-12 above for each cli-
ent machine on the network.

Renewing a floating license key code
To renew a floating license, enter the new license key code and product track-
ing ID on the network license server using the Pharsight Floating License 
Wizard for Server. No changes are necessary on the client machines.
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Chapter 3

Testing the Installation

Confirming proper installation of the main 
WinNonlin functions

Instructions follow to test the installation of WinNonlin using a number of the 
sample files provided with the software. This is not intended as a full valida-
tion of the product. It is intended to test for proper installation of major com-
ponents of the application. A complete validation kit is available from 
Pharsight Corporation. Contact the Pharsight sales department for more infor-
mation. 

File and window operations

To start WinNonlin:

1. From the Windows Start button, choose Program Files>Pharsight>Win-
Nonlin 4.1>WinNonlin 4.1. (Path may differ, depending on install location.)

The WinNonlin parent window appears with no file open.
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Loading a file

To open a sample file:

1. Click the Open toolbar button, or choose File>Open from the WinNonlin 
menus. The Open File dialog appears.

2. Select ASCII Data (*.dat, *.dta, *.prn, *.csv) as the file type.

3. Navigate to the EXAMPLES directory inside the WINNONLIN install directory.
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4. Double-click BGUIDE1.DAT in the list of files. The file opens in a workbook 
window, in the WinNonlin parent window.

BGUIDE1.DAT will be used to test key WinNonlin functions.

Creating a chart

To create a chart:

1. Click the Chart Wizard toolbar button.
or
Choose Tools>Chart Wizard from the WinNonlin menus. 

The Chart Wizard appears.
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2. Select XY Scatter as the graph type and click Next. A second dialog appears 
showing the variables in the BGuide1 dataset.

3. Click on Time under Variable Collection and drag it to the X-Variable field.

4. Click on Conc under Variable Collection and drag it to the Y-Variable field.

5. Click on the Sorting tab.

6. Drag Subject to the Sort Variables field. WinNonlin will create separate 
charts for each unique value of Subject. 

BGuide1 includes three subjects.
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7. Click Next to proceed to the final Chart Wizard dialog (not shown). 

8. Click Finish to close the wizard and create the new charts.

9. Use the page buttons  in the lower right corner of the chart 
window to move between profiles (subjects). 

The three charts are shown below, for comparison.
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Next, the BGuide1 data set will be used to test the Tables Wizard and its sum-
mary statistics function.
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Creating a table

To create a table:

1. Choose Window>Workbook - BGUIDE1.DAT in WinNonlin’s menus to 
move the workbook back into the active window.

2. Click the Table Wizard toolbar button.

The first dialog in the Table Wizard lists variables (at the bottom left) and the 
available templates for creating tables (at the top). The fields available in the 
selected template appear at the bottom right.

3. Select Table 1 to open a preview of that table format to the right.

4. Drag Time and Conc to the Variables field.

5. Drag Subject to the Group Variables field.
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6. Click Next. 
The next dialog in 
the sequence 
allows selection of 
summary statistics 
to be computed for 
the selected vari-
ables.

7. For this example, 
click All.

8. Click Next. 
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The dialog that appears sets the number of decimal places (or significant fig-
ures) and the alignment of numbers in the output table. For this example, 
accept the default settings.

9. Click Next. 

The next dialog in the sequence sets formatting of table elements, including 
the column titles, table body, header, and footer. The default settings will be 
used here.
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10. Click Finish to display the table in the Table Wizard window.

11. Click Create. 

The table should appear in a new workbook window, containing the data 
shown below.
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12. After comparing the output to these results, choose File>Close All from the 
menus. 

Modeling
This section will test an example of pharmacokinetic modeling and an exam-
ple of noncompartmental analysis.
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Compartmental modeling

To run compartmental modeling:

1. Click on the Open toolbar button. The File Open dialog appears.

2. Select Command Files (*.cmd) in the Files of type list.

3. Select EXP1.CMD in the WinNonlin EXAMPLES directory.

4. Click Open. This command file loads a data set, PK model, and modeling 
commands into WinNonlin.

5. Choose Model>Model Options from the menus or click on the Model 
Options toolbar button.

6. On the Output Options tab, confirm that workbook, chart and text output are 
all checked.

7. On the PK Settings tab, un-check the Transpose Final Parameter Table 
option, if necessary.

8. Click OK.

9. Select Model>Start Modeling from the menus or click the Start Modeling 
toolbar button. WinNonlin performs the modeling calculations and generates 
three new windows: PK Chart, PK Workbook and PK Text. 
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Workbook output

The output PK Workbook includes tabbed pages (worksheets) containing the 
following derived data. The same information is found in the PK Text win-
dow.

Initial Parameters
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Minimization Process

Final Parameters

Note: There should be two Final Parameters worksheets: that shown above, and an 
additional, transposed version. If the format of the Final Parameters work-
sheet differs from those displayed above, check that the Transpose Final 
Parameters Table checkbox was not checked in the PK Settings tab of the 
Model Options dialog (Model>Model Options).

Transposed Final Parameters (partial output shown)
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Dosing

Correlation Matrix

Eigenvalues

Condition Numbers
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Variance-Covariance Matrix

Summary Table

Note: The columns Time and Conc are not shown above, as they are the same as 
Time_Obs and Conc_Obs.

Diagnostics
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Partial Derivatives

Predicted Data
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Predicted Data (continued)

Secondary Parameters

Transposed Secondary Parameters (partial output shown)
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User Settings

Chart output

Additional chart types, not shown here, are produced in the model fitting.

Note: The output displayed in this chapter is intended only to test for proper installa-
tion of WinNonlin, and is not a full validation of the software. Those inter-
ested in a validation kit should send e-mail to sales@pharsight.com.

10. Close all open windows (File>Close All) in WinNonlin before proceeding to 
the next test, noncompartmental analysis.

mailto:sales@pharsight.com
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Noncompartmental analysis

To run noncompartmental analysis:

1. Open the command file PROFILES.CMD from the WinNonlin EXAMPLES direc-
tory. This will load a data set, model, and modeling settings.

2. Choose Model>Model Options from the menus. 

3. On the Output Options tab of the Model Options dialog, confirm that work-
book, chart and text output are all checked.

4. Open the NCA Settings tab and un-check Transpose Final Parameters, if 
necessary.

5. Click OK. 

6. Choose Model>Start Modeling from the menus. 

Three new output windows appear: NCA Chart, NCA Workbook and NCA 
Text. The text output contains the same data as the workbook, in ASCII form. 
Samples from the chart and workbook output are shown below.
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Chart output

 

Figure 3-1. Charts for subject 1. Observed and predicated concentrations for the 
capsule formulation (top) and tablet formulation (bottom).

NCA workbook output

The NCA Workbook contains multiple worksheets. Selections from the data 
are presented below.
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Final Parameters

Figure 3-2. Final parameter estimates for subject 1, capsule formulation only.
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Summary Table

Figure 3-3. Summary of noncompartmental analysis for subject 1.

Close all open windows before proceeding to the next example.

Bioequivalence 

Average bioequivalence

To test average bioequivalence:

1. Open the file SEQ2PER4.PWO from the WinNonlin EXAMPLES directory.

2. Start the Bioequivalence wizard: choose Tools>Bioequivalence Wizard from 
the menus or click the Bioequivalence Wizard toolbar button.

3. In the Bioequivalence Model dialog, make sure Crossover is selected as the 
type of study.

4. Make sure that Average is selected as the type of bioequivalence.
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5. Select R as the reference value and click Next. 

6. In the Bioequivalence Fixed Effects dialog, drag AUC to the Dependent 
Variables field.

7. Make sure the Dependent Variables Transformation is set to Ln(x).

8. Click Calculate. The new output is generated in a Bioequivalence workbook.
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The Partial Tests worksheet is not displayed here.
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Other worksheets generated from the modeling have been omitted for brevity. 

Close all open windows.
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Population/individual bioequivalence

To test population/individual bioequivalence:

1. Open the dataset RTR_TRT.PWO from the WinNonlin EXAMPLES directory.

2. Start the Bioequivalence wizard: choose Tools>Bioequivalence Wizard from 
the menus or click the Bioequivalence Wizard toolbar button.

3. Select Population/Individual as the type of bioequivalence. Crossover is the 
only study type allowed for population/individual bioequivalence.

4. Select R as the reference formulation and click Next. The Bioequivalence 
Fixed Effects dialog appears.

5. For Population/individual bioequivalence the model is preset (by FDA guide-
lines) and thus the model field cannot be changed. Drag AUC from the Vari-
able Collection to the Dependent Variables field.

6. Click Calculate. The output appears in a new Bioequivalence workbook.
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This bioequivalence example is complete. Close all open windows.

The examples in this chapter test the computational engines to insure that 
WinNonlin has been installed and operates properly.
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